OBBShortestSegmentTo Method (Line) |
Calculates the shortest LineSegment from OBB to the given Line.
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
Parameters
- line
- Type: Tekla.Structures.Geometry3dLine
Line to calculate against
Return Value
Type: LineSegmentShortest LineSegment from OBB to the given Line.
Exceptions
Exception | Condition |
---|---|
ArgumentNullException | Thrown when null is assigned to the line parameter. |
See Also