ShapeSelectionForm Constructor (ListShapeItem, String)

Initializes a new instance of the ShapeSelectionForm class, selecting the given Shape in the tree control.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public ShapeSelectionForm(
	List<ShapeItem> shapes,
	string shape
)

Parameters

shapes
Type: System.Collections.GenericListShapeItem
The Shapes to be added to the dialog.
shape
Type: SystemString
The Shape to be selected in the tree.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next