ShapeCatalog Class

The ShapeCatalog class represents a group of controls to select Shapes using the Shape catalog.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public class ShapeCatalog : UserControl

The ShapeCatalog type exposes the following members.

Constructors
  NameDescription
Public methodShapeCatalog
Initializes a new instance of the ShapeCatalog class.
Public methodShapeCatalog(String)
Initializes a new instance of the ShapeCatalog class and will select the Shape (if available) in the tree.
Top
Properties
  NameDescription
Public propertyButtonText
Gets and sets the text of the button control.
Public propertySelectedShape
Gets or sets the selected Shape in the control.
Top
Methods
  NameDescription
Public methodOnValueChanged
Event handler for passing generic catalog data back to dialog
Top
Events
  NameDescription
Public eventSelectClicked
The SelectClicked event is raised when the Select button is clicked.
Public eventSelectionDone
The SelectionDone event is raised when the selection has been done.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next