PluginSetAttribute Method (String, String)

Sets the specified attribute of the plug-in to the given value. NOTE! Only works on already inserted plug-ins.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public void SetAttribute(
	string FieldName,
	string fieldValue
)

Parameters

FieldName
Type: SystemString
The name of the attribute to set.
fieldValue
Type: SystemString
The value for the attribute.
Exceptions
ExceptionCondition
CannotSetAttributeForPluginException Thrown when setting the attribute to the plug-in failed for an unknown reason (might indicate an invalid plug-in name).
CannotSetAttributeForPluginDueToIncorrectTypeException Thrown when setting a value with an invalid type for the specified field.
CannotSetAttributeForPluginDueToInexistantFieldException Thrown when setting the value of an inexistent field.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next