PluginSetAttribute Method (String, Double) |
Sets the specified attribute of the plug-in to the given value.
NOTE! Only works on already inserted plug-ins.
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
Parameters
- FieldName
- Type: SystemString
The name of the attribute to set. - fieldValue
- Type: SystemDouble
The value for the attribute.
Exceptions
Exception | Condition |
---|---|
CannotSetAttributeForPluginException | Thrown when setting the attribute to the plug-in failed for an unknown reason (might indicate an invalid plug-in name). |
CannotSetAttributeForPluginDueToIncorrectTypeException | Thrown when setting a value with an invalid type for the specified field. |
CannotSetAttributeForPluginDueToInexistantFieldException | Thrown when setting the value of an inexistent field. |
See Also