RebarItemEnumeratorSelectRebarItem Method (String, Double, String, Boolean) |
Selects a rebar item in the rebar database with the given grade, nominal diameter and bending radius.
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
public static RebarItem SelectRebarItem( string Grade, double Diameter, string Usage, bool UseNominalDiameter )
Parameters
- Grade
- Type: SystemString
The grade of the rebar item to select. - Diameter
- Type: SystemDouble
The diameter of the rebar item to select. - Usage
- Type: SystemString
The usage of the rebar item to select. - UseNominalDiameter
- Type: SystemBoolean
If set to false, the item is selected based on the actual diameter. If true, the item is selected based on the nominal diameter.
Return Value
Type: RebarItemThe first RebarItem that matches the conditions.
See Also