RebarItemSelect Method (String, Double, Boolean)

Selects the rebar item in the rebar database.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
public bool Select(
	string Grade,
	double NominalDiameter,
	bool UseNominalDiameter
)

Parameters

Grade
Type: SystemString
The grade of the rebar item to select.
NominalDiameter
Type: SystemDouble
The diameter of the rebar item to select.
UseNominalDiameter
Type: SystemBoolean
If set to false, the item is selected based on the actual diameter. If true, the item is selected based on the nominal diameter.

Return Value

Type: Boolean
True on success.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next