SectionMark Constructor (View, Point, Point, SectionMarkBaseSectionMarkAttributes)

Creates a new section mark instance with the given positions and attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public SectionMark(
	View view,
	Point leftPoint,
	Point rightPoint,
	SectionMarkBaseSectionMarkAttributes sectionMarkAttributes
)

Parameters

view
Type: Tekla.Structures.DrawingView
The view to be used.
leftPoint
Type: Tekla.Structures.Geometry3dPoint
The starting point of the left side of the new section mark.
rightPoint
Type: Tekla.Structures.Geometry3dPoint
The starting point of the right side of the new section mark.
sectionMarkAttributes
Type: Tekla.Structures.DrawingSectionMarkBaseSectionMarkAttributes
The section mark attributes to be used.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next