SectionMarkBaseSectionMarkSymbolSymbolShapes Enumeration |
The possible shapes of the section mark symbol.
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
None | 1 | No symbol. | |
SymbolShape1 | 101 | The triangle with black and white halves. | |
SymbolShape2 | 102 | The arrow line pointing to an orthogonal straight line. | |
SymbolShape3 | 103 | The line with half of an arrow end. | |
SymbolShape4 | 104 | The rectangle shape with very small height. | |
SymbolShape5 | 105 | The triangle and circle shapes mixed. The circle partly hides the triangle. | |
SymbolShape6 | 106 | The triangle and circle shapes mixed. The triangle is on top. | |
SymbolShape7 | 107 | The triangle shape without content. | |
SymbolShape8 | 108 | The triangle shape filled in black. | |
Custom | 4 | The custom shape. |
See Also