SectionMarkBaseSectionMarkAttributes Class |
The SectionMarkAttributes class is the attributes class for section marks.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingSectionMarkBaseSectionMarkAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingSectionMarkBaseSectionMarkAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The SectionMarkBaseSectionMarkAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
SectionMarkBaseSectionMarkAttributes |
Creates a new default SectionMarkAttributes instance that loads standard attributes.
| |
SectionMarkBaseSectionMarkAttributes(String) |
Creates a new SectionMarkAttributes instance that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
LeftSymbol |
The symbol to use on the left side of the section mark.
| |
LineColor |
The color of the line.
| |
LineLength |
The length of the section mark lines.
| |
LineLengthOffset |
The offset from the end of the line on both sides of the section mark.
| |
LineWidth |
The width of the section mark lines.
| |
LineWidthOffsetLeft |
The offset from the start of the line on the left side of the section mark.
| |
LineWidthOffsetRight |
The offset from the start of the line on the right side of the section mark.
| |
MarkName |
The section mark name.
| |
RightSymbol |
The symbol to use on the right side of the section mark.
| |
SymbolColor |
The color of the mark symbols.
| |
TagsAttributes |
The tags A1-A5 in the section mark attributes.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) | |
LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |
See Also