SeamInputTypeAttribute Class |
The SeamInputTypeAttribute class is used for identifying that the connection is a seam and defining the input type.
Based on the type the system will then ask for the correct number of input points in the creation.
The attribute is initialized from the custom attribute
[SeamInputType(ConnectionBase.SeamInputType.INPUT_POLYGON)]
in the connection source.
Inheritance Hierarchy
Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
The SeamInputTypeAttribute type exposes the following members.
Constructors
Name | Description | |
---|---|---|
SeamInputTypeAttribute(Int32) |
The custom attribute [SeamInputType()] uses this to store the input type to the system.
This is not to be used by itself.
| |
SeamInputTypeAttribute(ConnectionBaseSeamInputType) |
The custom attribute [SeamInputType()] uses this to store the input type to the system.
This is not to be used by itself.
|
Properties
Name | Description | |
---|---|---|
Type |
The custom attribute [SeamInputType()] uses this to store the input type to the system.
This is not to be used by itself.
|
See Also