BentPlateGeometrySolverScaleConeSection Method

Scale the shape of a conical section.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public ConnectiveGeometry ScaleConeSection(
	ConnectiveGeometry geometry,
	GeometrySection conicalSection,
	double scale
)

Parameters

geometry
Type: Tekla.Structures.ModelConnectiveGeometry
Reference geometry to modify which contains conicalSection.
conicalSection
Type: Tekla.Structures.ModelGeometrySection
The conical geometry section to modify.
scale
Type: SystemDouble
Scale to apply to the conical section (greater than 0).

Return Value

Type: ConnectiveGeometry
Modified ConnectiveGeometry if command succeeded or geometry otherwise.
Exceptions
ExceptionCondition
ConnectiveGeometryExceptionThrown if could not modify the geometry.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next