PluginBaseRun Method

The main method of the plug-in. It is called after the input has been defined with DefineInput(). This is the "main" method of the plug-in and should contain all the actual implementation.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
public abstract bool Run(
	List<PluginBaseInputDefinition> Input
)

Parameters

Input
Type: System.Collections.GenericListPluginBaseInputDefinition
A list of the same format and order as what was returned from DefineInput().

Return Value

Type: Boolean
True on success.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next