ClashCheckHandlerRunClashCheckWithOptions Method (Boolean, Boolean, Double, Boolean)

Starts the clash checking with options.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public bool RunClashCheckWithOptions(
	bool betweenReferenceModels,
	bool objectsInsideReferenceModels,
	double minDistance,
	bool betweenParts
)

Parameters

betweenReferenceModels
Type: SystemBoolean
True, if clash check should be performed between reference models.
objectsInsideReferenceModels
Type: SystemBoolean
True, if clash check should be performed to objects inside reference models.
minDistance
Type: SystemDouble
The minimum distance value.
betweenParts
Type: SystemBoolean
True, if clash check should be performed between native parts.

Return Value

Type: Boolean
True on success.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next