Rotation3D Class |
Represents 3d rotation of object.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model.Geometry
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The Rotation3D type exposes the following members.
Constructors
Name | Description | |
---|---|---|
Rotation3D | Initializes a new instance of the Rotation3D class. | |
Rotation3D(Vector, Vector) | Initializes a new instance of the Rotation3D class. |
Properties
Methods
Name | Description | |
---|---|---|
Equals | Compares with another rotation. | |
FromZRotation | Creates Rotation3D which represents rotation around the Z axis. |
See Also