MatrixFactoryRotate Method |
Returns a rotation matrix in a Clockwise rotation around the given rotation axis,
defined by the given angle and the given rotation axis.
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
Parameters
- Angle
- Type: SystemDouble
The rotation angle (in radians). - Axis
- Type: Tekla.Structures.Geometry3dVector
The rotation axis.
Return Value
Type: MatrixThe new rotation matrix.
See Also