BentPlateGeometrySolverRemoveLeg Method |
Removes a polygon section which is the end section, from this ConnectiveGeometry including extensions and cylindrical surface.
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public ConnectiveGeometry RemoveLeg( ConnectiveGeometry geometry, GeometrySection legSection )
Parameters
- geometry
- Type: Tekla.Structures.ModelConnectiveGeometry
ConnectiveGeometry used to remove a connection. - legSection
- Type: Tekla.Structures.ModelGeometrySection
Leg GeometrySection to remove.
Return Value
Type: ConnectiveGeometryModified ConnectiveGeometry if command succeeded or geometry otherwise.
Exceptions
Exception | Condition |
---|---|
ArgumentException | Thrown when the supplied legSection is invalid leg section or geometry is a stand-alone bend geometry, meaning that the first GeometrySection is a BendSurfaceNode. |
See Also