![]() | ReinforcementSelectionForm Constructor (ListRebarItem, String, String, Double, String) |
Creates a new instance of the ReinforcementSelectionForm and will select in the tree
the rebar that contains the given parameters (if possible).
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
public ReinforcementSelectionForm( List<RebarItem> RebarList, string Size, string Grade, double BendRadius, string Usage )
Parameters
- RebarList
- Type: System.Collections.GenericListRebarItem
A list with the rebars that will be added to the tree. - Size
- Type: SystemString
The size of the rebar to be selected. - Grade
- Type: SystemString
The grade of the rebar to be selected. - BendRadius
- Type: SystemDouble
The bend radius of the rebar to be selected. - Usage
- Type: SystemString
The usage of the rebar to be selected.
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)