ReinforcementPulloutElement Class |
The ReinforcementPulloutElement class illustrates the shape and dimensions of a reinforcing bar in a drawing.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingElementBase
Tekla.Structures.DrawingReinforcementPulloutElement
Tekla.Structures.DrawingElementBase
Tekla.Structures.DrawingReinforcementPulloutElement
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The ReinforcementPulloutElement type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ReinforcementPulloutElement |
Creates a new reinforcement pull-out element instance.
|
Properties
Name | Description | |
---|---|---|
AutomaticScaling |
Gets or sets a value indicating whether the pull-out is scaled automatically or to a specified value.
| |
BendingAngle |
Gets or sets a value indicating whether to show the pull-out bending angles.
| |
BendingRadius |
Gets or sets a value indicating whether to show the pull-out bending radii.
| |
CouplersEndAnchorSymbols |
Gets or sets a value indicating whether to show coupler/anchor symbols or not.
| |
CouplersScale |
Gets or sets the scale of coupler/anchor symbols.
| |
Dimensioning |
Gets or sets a value indicating whether to show the pull-out dimensions.
| |
EndSymbolType |
Gets or sets the type of the ending marks.
| |
Exaggeration |
Gets or sets a value indicating whether the pull-out is exaggerated.
| |
Font |
Gets or sets the font of the dimension.
| |
RotationAxis |
Gets or sets the rotation of the pull-out.
| |
ScaleX |
Gets or sets the scaling of the pull-out in the X direction.
| |
ScaleY |
Gets or sets the scaling of the pull-out in the Y direction.
|
Methods
Name | Description | |
---|---|---|
Clone |
Clones the object.
(Overrides ElementBaseClone.) | |
GetUnformattedString |
Returns the content as a string without formatting.
(Overrides ElementBaseGetUnformattedString.) | |
IsEqual |
Compares the current object with an object of the same type.
(Overrides ElementBaseIsEqual(Object).) |
See Also