ReinforcementBase Class |
The ReinforcementBase class contains methods related to reinforcements.
A reinforcement is a drawing object derived from a model object.
It represents a drawing reinforcement that has a reference to the
actual reinforcement in the model database.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingModelObject
Tekla.Structures.DrawingReinforcementBase
Tekla.Structures.DrawingReinforcementGroup
Tekla.Structures.DrawingReinforcementMesh
Tekla.Structures.DrawingReinforcementSetGroup
Tekla.Structures.DrawingReinforcementSingle
Tekla.Structures.DrawingReinforcementStrand
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingModelObject
Tekla.Structures.DrawingReinforcementBase
Tekla.Structures.DrawingReinforcementGroup
Tekla.Structures.DrawingReinforcementMesh
Tekla.Structures.DrawingReinforcementSetGroup
Tekla.Structures.DrawingReinforcementSingle
Tekla.Structures.DrawingReinforcementStrand
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The ReinforcementBase type exposes the following members.
Properties
Name | Description | |
---|---|---|
Attributes |
The common attributes of all reinforcements.
For more information see ReinforcementBaseReinforcementBaseAttributes.
| |
Hideable |
Accesses the information if this object is hidden or not or if it should be.
(Inherited from ModelObject.) | |
ModelIdentifier |
The database identifier of the model object in the model database.
By using this identifier, it is possible to select the actual object
in the Tekla Structures model.
(Inherited from ModelObject.) | |
QueryReturnValue |
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.) |
Methods
Name | Description | |
---|---|---|
Delete |
Deletes the drawing reinforcement from the current drawing database.
(Overrides DatabaseObjectDelete.) | |
GetDoubleUserProperties(DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDoubleUserProperties(ListString, DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDrawing |
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.) | |
GetIntegerUserProperties(DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetIntegerUserProperties(ListString, DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetRelatedObjects |
Gets the related objects of the current object.
(Inherited from DrawingObject.) | |
GetRelatedObjects(Type) |
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.) | |
GetStringUserProperties(DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetStringUserProperties(ListString, DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetView |
Gets the view where the drawing object is.
(Inherited from DrawingObject.) | |
Insert |
Inserts the drawing reinforcement into the current drawing database.
NOT YET IMPLEMENTED.
(Overrides DatabaseObjectInsert.) | |
IsEqual |
Compares the current object with the given object.
Checks every field of both objects for equality.
(Inherited from DrawingObject.) | |
IsSameDatabaseObject |
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.) | |
Modify |
Modifies the drawing reinforcement in the current drawing database.
(Overrides DatabaseObjectModify.) | |
Select |
Selects the drawing reinforcement from the current drawing database.
(Overrides DatabaseObjectSelect.) | |
SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
ToString |
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.) |
See Also