ReinforcementBase Class |
The ReinforcementBase class contains methods related to reinforcements.
A reinforcement is a drawing object derived from a model object.
It represents a drawing reinforcement that has a reference to the
actual reinforcement in the model database.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingModelObject
Tekla.Structures.DrawingReinforcementBase
Tekla.Structures.DrawingReinforcementGroup
Tekla.Structures.DrawingReinforcementMesh
Tekla.Structures.DrawingReinforcementSetGroup
Tekla.Structures.DrawingReinforcementSingle
Tekla.Structures.DrawingReinforcementStrand
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingModelObject
Tekla.Structures.DrawingReinforcementBase
Tekla.Structures.DrawingReinforcementGroup
Tekla.Structures.DrawingReinforcementMesh
Tekla.Structures.DrawingReinforcementSetGroup
Tekla.Structures.DrawingReinforcementSingle
Tekla.Structures.DrawingReinforcementStrand
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The ReinforcementBase type exposes the following members.
Properties
Name | Description | |
---|---|---|
Attributes |
The common attributes of all reinforcements.
For more information see ReinforcementBaseReinforcementBaseAttributes.
ModelIdentifier |
The database identifier of the model object in the model database.
By using this identifier, it is possible to select the actual object
Methods
Name | Description | |
---|---|---|
Delete |
Deletes the drawing reinforcement from the current drawing database.
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
Insert |
Inserts the drawing reinforcement into the current drawing database.
NOT YET IMPLEMENTED.
Modify |
Modifies the drawing reinforcement in the current drawing database.
(Overrides DatabaseObjectModify.) | |
Select |
Selects the drawing reinforcement from the current drawing database.
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
See Also