ImageListComboBoxRefreshOptionList Method

Refreshes the option list content.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public void RefreshOptionList()
Examples
The following example demonstrates how to programmatically add a new item to the combo box:
using System;
using System.Drawing;
using System.Windows.Forms;
using Tekla.Structures.Dialog.UIControls;

public class ImageListComboBoxExample
{
    private ImageListComboBox ImageListComboBox;

    public ImageListComboBoxExample()
    {
        ImageListComboBox = new ImageListComboBox();
    }

    void AddNewImage()
    {
        ImageListComboBox.ImageList.Images.Add("ImageKey", new Bitmap(@"C:\Image.bmp"));
        ImageListComboBox.RefreshOptionList();
    }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next