ReferenceModelObjectAttributeAttributeTypeEnum Enumeration

All the reference model object attribute types.

Namespace:  Tekla.Structures.Model.Collaboration
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public enum AttributeTypeEnum
Members
  Member nameValueDescription
ATTRIBUTETYPE_INVALID0 The invalid attribute type.
ATTRIBUTETYPE_IFC2X3_PARAMETRICOBJECT_CSHAPEPROFILE3 The C-shape profile attribute type.
ATTRIBUTETYPE_IFC2X3_PARAMETRICOBJECT_CIRCLEHOLLOWPROFILE4 The circular and hollow profile attribute type.
ATTRIBUTETYPE_IFC2X3_PARAMETRICOBJECT_CIRCLEPROFILE5 The circular profile attribute type.
ATTRIBUTETYPE_IFC2X3_PARAMETRICOBJECT_ELLIPSEPROFILE6 The ellipse profile attribute type.
ATTRIBUTETYPE_IFC2X3_PARAMETRICOBJECT_ISHAPEPROFILE7 The I-shape profile attribute type.
ATTRIBUTETYPE_IFC2X3_PARAMETRICOBJECT_LSHAPEPROFILE8 The L-shape profile attribute type.
ATTRIBUTETYPE_IFC2X3_PARAMETRICOBJECT_RECTANGLEHOLLOWPROFILE9 The rectangular and hollow profile attribute type.
ATTRIBUTETYPE_IFC2X3_PARAMETRICOBJECT_RECTANGLEPROFILE10 The rectangular profile attribute type.
ATTRIBUTETYPE_IFC2X3_PARAMETRICOBJECT_TSHAPEPROFILE11 The T-shape profile attribute type.
ATTRIBUTETYPE_IFC2X3_PARAMETRICOBJECT_USHAPEPROFILE12 The U-shape profile attribute type.
ATTRIBUTETYPE_IFC2X3_PARAMETRICOBJECT_ZSHAPEPROFILE13 The Z-shape profile attribute type.
ATTRIBUTETYPE_PARAMETRICOBJECT_CUSTOMPROFILE14 The custom profile attribute type.
ATTRIBUTETYPE_PARAMETRICOBJECT_OBB29 The object bounding box (OBB) attribute type.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next