ReferenceModel Constructor

Initializes a new instance of the ReferenceModel class.

The default values are as follows:

  • Filename = string.Empty;
  • ActiveFilePath = string.Empty;
  • ProjectGUID = Guid.Empty;
  • ModelGUID = Guid.Empty;
  • VersionGUID = Guid.Empty;
  • Position = new Point();
  • Scale = 1.0;
  • Visibility = VisibilityEnum.VISIBLE;
  • BasePointGuid = string.Empty;

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public ReferenceModel()
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next