Rectangle Constructor (ViewBase, Point, Point)

Creates a new rectangle instance with two points using standard attributes. Please note that creating a rectangle using two points will re-calculate the start point to correspond with positive widths and heights.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public Rectangle(
	ViewBase view,
	Point startPoint,
	Point endPoint
)

Parameters

view
Type: Tekla.Structures.DrawingViewBase
The view to be used.
startPoint
Type: Tekla.Structures.Geometry3dPoint
The start point to be used.
endPoint
Type: Tekla.Structures.Geometry3dPoint
The end point to be used.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next