RebarSpacingZone Class |
The RebarSpacingZone class defines the properties of a single spacing zone.
The spacing properties of number of spaces, spacing and length are proposed properties that the spacing algorithm uses as input when calculating the
final reinforcing bars spacing.
Depending on the RebarSpacingZone properties and any other rebar spacing zones defined on the associated RebarGuideline the spacing algorithm may
determine a different final reinforcing bars spacing from the original proposed properties. However the RebarSpacingZone properties will always contain the
original proposed values.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The RebarSpacingZone type exposes the following members.
Constructors
Name | Description | |
---|---|---|
RebarSpacingZone |
Initializes a new instance of the RebarSpacingZone class.
|
Properties
Name | Description | |
---|---|---|
Length |
Gets or sets the proposed overall spacing zone length.
| |
LengthType |
Gets or sets a value indicating whether the length is absolute or relative.
If the length is relative the length property is treated as a proportion of the overall available spacing length (from the associated RebarGuideline).
The available spacing length is the guideline length less the calculated start and end offsets and less any fixed length spacing zones.
An example of how relative length values are handled:
With two relative length zones with proposed length values of 10 and 20 respectively the final calculated lengths will normally be
'available spacing length'*10/(10+20) and 'available spacing length'*20/(10+20) though the spacing algorithm may determine a different result in some situations.
| |
NumberOfSpaces |
Gets or sets the proposed number of spaces in the spacing zone.
| |
NumberOfSpacesType |
Gets or sets a value indicating whether the number of spaces is exact or target.
If the number of spaces is target the spacing algorithm may determine a different number of spaces to use.
| |
Spacing |
Gets or sets the proposed spacing (the space between each reinforcing bar centerline) in the spacing zone.
| |
SpacingType |
Gets or sets a value indicating whether the spacing is exact or target.
If the spacing is target the spacing algorithm may determine a different spacing to use.
|
See Also