RebarSpacingSpacingType Enumeration |
Defines the different spacing types.
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
UNDEFINED | 0 | Undefined spacing. | |
EXACT_SPACINGS | 1 | Explicitly defined exact spacings. | |
NUMBER_BARS | 2 | Spacing by number of bars. | |
TARGET | 3 | Spacing by target distance. | |
EXACT_FLEXIBLE_FIRST | 4 | Exact spacing with flexible first space. | |
EXACT_FLEXIBLE_LAST | 5 | Exact spacing with flexible last space. | |
EXACT_FLEXIBLE_FIRST_AND_LAST | 6 | Exact spacing with flexible first and last space. | |
EXACT_FLEXIBLE_MIDDLE | 7 | Exact spacing with flexible middle space. |
See Also