RebarSpacing Class |
The RebarSpacing class defines spacing properties for a RebarGuideline.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The RebarSpacing type exposes the following members.
Constructors
Name | Description | |
---|---|---|
RebarSpacing |
Initializes a new instance of the RebarSpacing class.
|
Properties
Name | Description | |
---|---|---|
EndOffset |
Gets or sets the proposed offset to the last reinforcing bar from the end of the RebarGuideline.
| |
EndOffsetIsAutomatic |
Gets or sets a value indicating whether the end offset is automatic.
When automatic the proposed end offset is calculated to be the concrete cover thickness plus half the reinforcing bar diameter.
| |
EndOffsetType |
Gets or sets a value indicating whether the end offset is exact or minimum.
If the end offset is minimum the spacing algorithm may determine a larger offset.
| |
ExactElements |
Gets or sets the exact elements of the spacing.
| |
ExactSpace |
Gets or sets the exact space.
| |
ExcludeType |
Gets or sets the exclusion of first and last bars.
| |
InheritFromPrimary |
Gets or sets a value indicating whether the secondary guideline inherits all its spacing properties from the
primary guideline.
This property is not applicable to a primary guideline.
| |
NumberOfBars |
Gets or sets the number of bars in the spacing object.
| |
StartOffset |
Gets or sets the proposed offset to the first reinforcing bar from the start of the RebarGuideline.
| |
StartOffsetIsAutomatic |
Gets or sets a value indicating whether the start offset is automatic.
When automatic the proposed start offset is calculated to be the concrete cover thickness plus half the reinforcing bar diameter.
| |
StartOffsetType |
Gets or sets a value indicating whether the start offset is exact or minimum.
If the start offset is minimum the spacing algorithm may determine a larger offset.
| |
TargetSpace |
Gets or sets the target space.
| |
Type |
Gets or sets the type of spacing. Does not allow change to exact spacing or number bars spacing.
| |
Zones |
Gets or sets the spacing zones.
|
Methods
Name | Description | |
---|---|---|
Clone |
Makes a copy of this object.
| |
Create(RebarSpacingOffset, RebarSpacingOffset, Int32) |
Craetes a spacing defined by number of bars.
| |
Create(RebarSpacingOffset, RebarSpacingOffset, IEnumerableRebarSpacingExactSpacingElement, RebarSpacingExactSpacingValidation) |
Creates an exact spacing if the given elements are valid.
| |
Create(RebarSpacingSpacingType, RebarSpacingOffset, RebarSpacingOffset, Double) |
Create a spacing which is defined by a single distance.
| |
IsExactFlexibleType |
Gets whether the spacing is an exact type with flexible space(s).
|
See Also