RebarPropertiesNullable Class |
The RebarPropertiesNullable class defines the properties of the reinforcing bars affected by a RebarPropertyModifier.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The RebarPropertiesNullable type exposes the following members.
Constructors
Name | Description | |
---|---|---|
RebarPropertiesNullable |
Initializes a new instance of the RebarPropertiesNullable class.
|
Properties
Name | Description | |
---|---|---|
BendingRadius |
Gets or sets the bending radius radius of the reinforcement.
| |
Class |
Gets or sets the class of the reinforcement. The class is used to group reinforcements.
| |
Grade |
Gets or sets the steel grade of the reinforcing bar.
The grade indicates the strength of the steel used in reinforcing bars.
It can also indicate other factors, such as the weldability or surface deformations of the bar.
| |
Name |
Gets or sets the name of the reinforcement.
| |
NumberingSeries |
Gets or sets the numbering series of the reinforcement.
| |
Size |
Gets or sets the size of the reinforcement.
|
See Also