RebarLegFace Class |
Defines a rebar leg face that is used in a RebarSet.
Rebar leg faces control how the RebarSet generates the reinforcing bars.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The RebarLegFace type exposes the following members.
Constructors
Name | Description | |
---|---|---|
RebarLegFace |
Initializes a new instance of the RebarLegFace class.
| |
RebarLegFace(Contour) |
Initializes a new instance of the RebarLegFace class using the specified Contour.
|
Properties
Name | Description | |
---|---|---|
AdditonalOffset |
Gets or sets the user defined offset of the rebars from the rebar leg face.
| |
Contour |
Gets or sets the outer Contour of the rebar leg face.
| |
Id |
Gets or sets an identifier that may be used to identify instances of the same rebar leg face.
| |
LayerOrderNumber |
Gets or sets the layer order number of the rebar leg face.
| |
Reversed |
Gets or sets a value indicating whether the cover thickness is opposite to the coordinate system Z direction for the rebar leg face.
|
See Also