RebarItemEnumerator Class |
The RebarItemEnumerator class allows to loop through the catalog rebar items.
Inheritance Hierarchy
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
The RebarItemEnumerator type exposes the following members.
Properties
Methods
Name | Description | |
---|---|---|
DeleteRebarItem |
Delete the RebarItem from the list
| |
GetRebarHeaderItems |
Gets the header items from the rebar catalog header.
| |
GetSize |
Returns the total amout of items.
| |
InsertRebarItem |
Insert the RebarItem in to the list
| |
ModifyRebarItem |
Modify the RebarItem in the list
| |
MoveNext |
Moves to the next item in the enumerator.
| |
RebarItemExists |
Check RebarItem is available in database file
| |
Reset |
Resets the enumerator to the beginning.
| |
SelectRebarItem(String, String) |
Selects a rebar item in the rebar database with the given grade and size.
| |
SelectRebarItem(String, Double, Boolean) |
Selects a rebar item in the rebar database with the given grade and nominal diameter.
| |
SelectRebarItem(String, String, Double) |
Selects a rebar item in the rebar database with the given grade, size and bending radius.
| |
SelectRebarItem(String, String, String) |
Selects a rebar item in the rebar database with the given grade, size and usage.
| |
SelectRebarItem(String, Double, Double, Boolean) |
Selects a rebar item in the rebar database with the given grade, nominal diameter and bending radius.
| |
SelectRebarItem(String, Double, String, Boolean) |
Selects a rebar item in the rebar database with the given grade, nominal diameter and bending radius.
| |
SelectRebarItem(String, String, String, String) |
Selects a rebar item in the rebar database with the given grade, size, usage and code.
|
See Also