RebarGuideline Class |
Defines a rebar guideline that is used in a RebarSet.
A RebarSet has a minimum of one rebar guideline, the primary guideline.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The RebarGuideline type exposes the following members.
Constructors
Name | Description | |
---|---|---|
RebarGuideline |
Initializes a new instance of the RebarGuideline class.
|
Properties
Name | Description | |
---|---|---|
Curve |
Gets or sets the geometric Contour of the rebar guideline.
| |
FollowEdges |
Gets or sets a flag that indicates whether the guideline should attempt to follow
the leg face edges located between its end points.
| |
Id |
Gets or sets an identifier that may be used to identify instances of the same rebar guideline.
| |
Spacing |
Gets or sets the RebarSpacing along the rebar guideline.
|
See Also