RebarGeometry Class

The RebarGeometry class represents a single physical reinforcing bar - the building block of a mesh, a rebar group and even a single rebar. It contains the physical reinforcing bar points in 3D space.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelRebarGeometry

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class RebarGeometry

The RebarGeometry type exposes the following members.

Properties
  NameDescription
Public propertyBendingRadiuses
The bending radiuses of the wire.
Public propertyDiameter
The diameter of the wire.
Public propertyShape
The physical points of the reinforcing bar.
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

using System;
using System.Collections;

public class Example
{
       public void Example1()
       {
           RebarGroup Group = new RebarGroup();
           ArrayList RebarGeoms = Group.GetRebarGeometries(true);
           foreach (RebarGeometry Rebar in RebarGeoms)
           {
               if (Rebar != null)
               {
                   Console.WriteLine("Wire {0} has the following points:");
                   foreach (Point p in Rebar.Shape.Points)
                   {
                       Console.WriteLine("[{0},{1},{2}]", p.X, p.Y, p.Z);
                   }
               }
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next