RebarCranking Class

The RebarCranking class represents the cranking of reinforcing bars at a RebarSplitter.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelRebarCranking

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class RebarCranking

The RebarCranking type exposes the following members.

Constructors
  NameDescription
Public methodRebarCranking
Initializes a new instance of the RebarCranking class.
Top
Properties
  NameDescription
Public propertyCrankedDistance
Gets or sets the cranked distance.
Public propertyCrankedLengthType
Gets or sets the cranked length type.
Public propertyCrankedOffset
Gets or sets the cranked offset.
Public propertyCrankedRatio
Gets or sets the cranked ratio.
Public propertyCrankingType
Gets or sets the cranking type.
Public propertyCrankRotation
Gets or sets the crank rotation.
Public propertyCrankSide
Gets or sets the crank side.
Public propertyCrankStraightLength
Gets or sets the crank straight length.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next