RebarComplexGeometry Class

The ReinforcingBar class represents a single physical reinforcing bar. It contains the curves and bendings that define the geometry of the bar.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelRebarComplexGeometry

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class RebarComplexGeometry

The RebarComplexGeometry type exposes the following members.

Properties
  NameDescription
Public propertyBendingRadiuses
The bending radiuses of the wire.
Public propertyDiameter
Gets the diameter of the wire.
Public propertyLegs
Gets the list of RebarLegs of the bar.
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

using System;
using System.Collections;

public class Example
{
    public void Example1()
    {
        var rebarGroup = new RebarGroup();
        var barGeometries = rebarGroup.GetRebarComplexGeometries(true, true, true);
        foreach (RebarComplexGeometry barGeom in barGeometries)
        {
            Console.WriteLine("Bar has the following curves:");
            foreach (var leg in barGeom.Legs)
            {
                if (leg.Curve is LineSegment)
                {
                    Console.Write("Line ");
                }
                else if (leg.Curve is Arc)
                {
                    Console.Write("Arc ");
                }
            }
            Console.WriteLine();
        }
    }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next