RadiusDimension Constructor (ViewBase, Point, Point, Point, Double, RadiusDimensionAttributes) |
Creates a new radius dimension instance with the attributes, three points and the distance.
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public RadiusDimension( ViewBase View, Point ArcPoint1, Point ArcPoint2, Point ArcPoint3, double Distance, RadiusDimensionAttributes Attributes )
Parameters
- View
- Type: Tekla.Structures.DrawingViewBase
The view to be used. - ArcPoint1
- Type: Tekla.Structures.Geometry3dPoint
The first arc point to be used. - ArcPoint2
- Type: Tekla.Structures.Geometry3dPoint
The second arc point to be used. - ArcPoint3
- Type: Tekla.Structures.Geometry3dPoint
The third arc point to be used. - Distance
- Type: SystemDouble
The distance to be used. - Attributes
- Type: Tekla.Structures.DrawingRadiusDimensionAttributes
The attributes to be used.
See Also