RadiusDimensionAttributes Class |
The RadiusDimensionAttributes class contains attributes to manage all the attributes of a straight dimension.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingRadiusDimensionAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingRadiusDimensionAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The RadiusDimensionAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
RadiusDimensionAttributes |
Creates a new radius dimension attributes instance which loads standard attributes.
| |
RadiusDimensionAttributes(String) |
Creates a new radius dimension attributes instance that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
Arrowhead |
The arrowhead attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) | |
Color |
The color of the dimension line.
(Inherited from DimensionSetBaseAttributes.) | |
Format |
The format attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) | |
Placing |
The placing attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) | |
Text |
The text attributes of the dimension.
(Inherited from DimensionSetBaseAttributes.) | |
TransparentBackground |
The dimension text background transparency. (transparent/opaque)
(Inherited from DimensionSetBaseAttributes.) |
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) | |
LoadAttributes |
Loads attributes from the specified attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |
Examples
using Tekla.Structures.Drawing; public class Example { public void Example1() { RadiusDimensionAttributes attributes = new RadiusDimensionAttributes("MyAttributes"); } }
See Also