PropertyElement Class |
The PropertyElement class may represent any of the many different mark element types, such as the profile, the material and the name.
The property is defined by the name and it is converted into a textual value before the mark is drawn.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The PropertyElement type exposes the following members.
Constructors
Name | Description | |
---|---|---|
PropertyElement |
Creates a new property element instance with the given property element type.
|
Properties
Name | Description | |
---|---|---|
Font |
The font of the property.
| |
Name |
The property name.
| |
PropertyType |
The type of the property element.
| |
Value |
The current value of the property.
|
Methods
Name | Description | |
---|---|---|
Clone |
Clones the object.
(Overrides ElementBaseClone.) | |
GetUnformattedString |
Returns the content as a string without formatting.
(Overrides ElementBaseGetUnformattedString.) | |
IsEqual |
Compares the current object with an object of the same type.
(Overrides ElementBaseIsEqual(Object).) |
See Also