Projection Class |
The Projection class contains methods for calculating the projection of geometric objects on
other geometric objects.
Inheritance Hierarchy
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
The Projection type exposes the following members.
Methods
Name | Description | |
---|---|---|
LineSegmentToPlane |
Returns a new line segment which is a projection of the given line segment onto the given plane.
| |
LineToPlane |
Returns a new line which is a projection of the given line onto the given plane.
| |
PointToLine |
Returns a new point which is a projection of the given point onto the given line.
| |
PointToPlane |
Returns a new point which is a projection of the given point onto the given plane.
|
See Also