ProfileProfileString Property

The profile in human-readable form.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public string ProfileString { get; set; }

Property Value

Type: String
Examples
The profile of a beam is set to standard L profile "L400*200*60":
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           Point point = new Point(5000, 0, 0);
           Point point2 = new Point(7000, 0, 0);
           Beam Beam = new Beam(point, point2);

           string ParametricProfileSeparator = "*";
           string ShapeTypeL = "L";
           string LshapeProfileDepth = "400";
           string LshapeProfileWidth = "200";
           string LshapeProfileThickness = "60";

           Beam.Profile.ProfileString = ShapeTypeL;
           Beam.Profile.ProfileString += LshapeProfileDepth;
           Beam.Profile.ProfileString += ParametricProfileSeparator;
           Beam.Profile.ProfileString += LshapeProfileWidth;
           Beam.Profile.ProfileString += ParametricProfileSeparator;
           Beam.Profile.ProfileString += LshapeProfileThickness;
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next