ProfileItemProfileItemTypeEnum Enumeration |
Defines the different profile item types.
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
ALL_PROFILES | -1 | All profiles. | |
PROFILE_UNKNOWN | 0 | The unknown profile. | |
PROFILE_I | 1 | The I profile. | |
PROFILE_L | 2 | The L profile. | |
PROFILE_Z | 3 | The Z profile. | |
PROFILE_U | 4 | The U profile. | |
PROFILE_PL | 5 | The plate profile. | |
PROFILE_D | 6 | The circular section profile. | |
PROFILE_PD | 7 | The circular hollow section profile. | |
PROFILE_P | 8 | The rectangular hollow section profile. | |
PROFILE_C | 9 | The C profile. | |
PROFILE_T | 10 | The T profile. | |
PROFILE_HK | 11 | The welded box profile. | |
PROFILE_HQ | 13 | The HQ profile | |
PROFILE_ZZ | 15 | The ZZ profile. | |
PROFILE_CC | 16 | The CC profile. | |
PROFILE_CW | 17 | The CW profile. | |
PROFILE_CU | 18 | The CU profile. | |
PROFILE_EB | 19 | The EB profile. | |
PROFILE_BF | 20 | The BF profile. | |
PROFILE_SPD | 21 | The SPD profile. | |
PROFILE_EC | 22 | The EC profile. | |
PROFILE_ED | 23 | The ED profile. | |
PROFILE_EE | 24 | The EE profile. | |
PROFILE_EF | 25 | The EF profile. | |
PROFILE_EZ | 26 | The EZ profile. | |
PROFILE_EW | 27 | The EW profile. | |
PROFILE_POLYGON_PLATE | 51 | The polygon plate profile. | |
PROFILE_FPL | 2 | The FPL profile. | |
PROFILE_SP | 101 | The SP profile. | |
PROFILE_RCDL | 102 | The RCDL profile. | |
PROFILE_RCXX | 103 | The RCXX profile. | |
PROFILE_RCL | 104 | The RCL profile. | |
PROFILE_RCDX | 105 | The RCDX profile. | |
PROFILE_RCX | 106 | The RCX profile. | |
PROFILE_USER_DEFINED | 998 | The user-defined, fixed profile. | |
PROFILE_USER_PARAMETRIC | 999 | The user-defined, parametric profile. |
See Also