ProfileItemParameter Class

The ProfileItemParameter class contains the information of one profile parameter (property name, symbol, unit and unit type). A profile item can contain a maximum of 50 profile parameters.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsProfileItemParameter

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ProfileItemParameter

The ProfileItemParameter type exposes the following members.

Constructors
  NameDescription
Public methodProfileItemParameter
Initializes a new instance of the ProfileItemParameter class
Top
Properties
  NameDescription
Public propertyCrossSectionNumber
The number of the cross section the parameter belongs to.
Public propertyParameterUnitType
Defines the parameter unit type.
Public propertyProperty
The description of the profile item parameter. Corresponds to the 'Property' in the Tekla Structures profile catalog dialog, and the 'Label in dialog box' in the variable dialog in the Sketch Editor.
Public propertyStringValue
The string value of the profile item parameter.
Public propertySymbol
The symbol of the profile item parameter.
Public propertyValue
The value of the profile item parameter.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next