PrinterItem Class |
The PrinterItem class contains information about the printers in the Tekla Structures catalog.
Inheritance Hierarchy
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
The PrinterItem type exposes the following members.
Constructors
Name | Description | |
---|---|---|
PrinterItem |
Creates a new printer item instance.
|
Properties
Name | Description | |
---|---|---|
Device |
The actual printer device used in the printing.
| |
Extension |
The printer item's default file extension which is used when printing to a file.
| |
Name |
The printer item's name which Tekla Structures uses
to fetch all the item's default properties in the printing process.
| |
PrintAreaHeigth |
The printer item's print area height.
| |
PrintAreaWidth |
The printer item's print area width.
|
See Also