PourObject Class

The PourObject class represents a pour object in the model.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class PourObject : ModelObject, IAssemblable

The PourObject type exposes the following members.

Constructors
  NameDescription
Public methodPourObject
Initializes a new instance of the PourObject class.
Top
Properties
  NameDescription
Public propertyClass
Gets or sets the class of the pour object.
Public propertyConcreteMixture
Gets or sets the concrete mixture of the pour.
Public propertyPourNumber
Gets or sets the pour number of the pour.
Public propertyPourType
Gets or sets the pour type of the pour.
Top
Methods
  NameDescription
Public methodDelete
At the moment pour objects cannot be deleted.
(Overrides ModelObjectDelete.)
Public methodGetAssembly Obsolete.
Returns the assembly that the pour object belongs to.
Public methodGetFatherPourUnit
Returns the pour unit that the pour object belongs to.
Public methodGetObjects
Returns an enumerator of all objects related to pour.
Public methodGetParts
Returns an enumerator of all parts related to pour.
Public methodGetPourPolymeshes
Returns a new polymesh enumerator based on merged faces of the pour object in the current plane.
Public methodGetSolid
Returns the solid of the pour object.
Public methodGetSurfaceObjects
Returns an enumerator of all the connected surface objects.
Public methodInsert
At the moment pour objects cannot be inserted.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the pour object with the given identifier.
(Overrides ModelObjectModify.)
Public methodSelect
Selects the pour object instance from the model. The identifier of the instance must be set.
(Overrides ModelObjectSelect.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;
using System;
using System.Collections;

public class Example
{
    public void Example1()
    {
        Beam beam = new Beam(new Point(1000, 1000, 400), new Point(3000, 1000, 400));
        beam.Profile.ProfileString = "380*380";
        beam.Material.MaterialString = "K40-1";
        beam.CastUnitType = Part.CastUnitTypeEnum.CAST_IN_PLACE;
        if (beam.Insert())
        {
            Beam beam2 = new Beam(new Point(800, 1000, 0), new Point(800, 1000, 3000));
            beam2.Profile.ProfileString = "380*380";
            beam2.Material.MaterialString = "K40-1";
            beam2.CastUnitType = Part.CastUnitTypeEnum.CAST_IN_PLACE;
            if (beam2.Insert())
            {
                new Model().CommitChanges();
                ModelObjectEnumerator pours = beam.GetPours();
                while(pours.MoveNext())
                {
                    PourObject pour = pours.Current as PourObject;
                    if(pour != null)
                    {
                        Solid solid = pour.GetSolid();
                        if(solid != null)
                            Console.WriteLine("Fetching solid from pour successfully!");
                    }
                }
            }         
        }
    }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next