PourBreakPourBreakAttributes Class |
The PourBreakAttributes class is the attributes class for the pour break.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingPourBreakPourBreakAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingPourBreakPourBreakAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The PourBreakPourBreakAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
PourBreakPourBreakAttributes |
Creates a new default pour break attributes instance that loads standard attributes.
| |
PourBreakPourBreakAttributes(String) |
Creates a new pour break attributes instance that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
DrawHiddenLines |
Indicates whether hidden lines are used to draw the pour break or not.
| |
HiddenLines |
The hidden line type of the pour break.
| |
VisibleLines |
The visible line type of the pour break.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) | |
LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |
See Also