![]() | PositionTypeAttribute Class |
The PositionTypeAttribute class is used for storing the position type of the connection.
Based on the type the system will then position the connection in the creation.
The attribute is initialized from the custom attribute
[PositionType(PositionTypeEnum.COLLISION_PLANE)]
in the connection source.

Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3

The PositionTypeAttribute type exposes the following members.

Name | Description | |
---|---|---|
![]() | PositionTypeAttribute(Int32) |
The custom attribute [PositionType()] uses this to store the position type to the system.
This is not to be used by itself.
|
![]() | PositionTypeAttribute(PositionTypeEnum) |
The custom attribute [PositionType()] uses this to store the position type to the system.
This is not to be used by itself.
|

Name | Description | |
---|---|---|
![]() | Type |
The custom attribute [PositionType()] uses this to store the position type to the system.
This is not to be used by itself.
|