PolymeshPolymeshHealthCheckEnum Enumeration |
Polymesh check error result codes. See the PolymeshCheckerFlags to see how to set the various checks.
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
PolymeshLevelError | -2 | The vertex array contains vertices that are geometrically equivalent or the polymesh contains unused vertices | |
PolymeshUndefined | -1 | Polymesh is null, the creation failed or unknown reasons. | |
PolymeshOk | 0 | Valid polymesh | |
NumOfVerticesOuterloop | 1 | Number of vertices in outer loop too small | |
NumOfVerticesInnerloop | 2 | Number of vertices in innerloop too small | |
VertexArrayOuterloop | 3 | Check of indices of vertices in outer loop failed | |
VertexArrayInnerloop | 4 | Check of indices of vertices in the innerloop failed | |
InnerloopNotInsideOuterloop | 5 | Inner loop is not inside the outer loop | |
VertexArrayForListOfEdges | 6 | Check of indices of vertices for edge list failed | |
NonPlanarOuterloop | 7 | Outer loop points are not in the same plane with each other | |
NonPlanarInnerloop | 8 | Inner loop points are not in the same plane with each other or with outer loop | |
SelfIntersectingOuterloop | 9 | Outer loop is self-intersecting | |
SelfIntersectingInnerloop | 10 | Inner loop is self-intersecting | |
LoopNormalsInvalid | 11 | Inner loop normal direction should be opposite to outer loop | |
FaceEdgesInvalidOrientation | 12 | Two neighbor faces with common edge have wrong orientation | |
FaceEdgesPartlyInvalidOrientation | 13 | Two neighbor faces with partly common edge have wrong orientation | |
MultishellPolymesh | 14 | Polymesh consists topologically of multiple shells | |
MultishellPolymeshByGeometry | 21 | Polymesh consists geometrically of multiple shells | |
NumberOfFaces | 15 | Number of faces too small | |
VertexArrayUniqueness | 16 | The vertex array contains vertices that are geometrically equivalent | |
VertexDuplicatesOnPolygon | 17 | The same vertex index appears at least twice for a face | |
VertexCollinearOnPolygon | 18 | The face has at least one vertex that is collinear with others on an edge | |
NonManifoldEdges | 19 | The polymesh contains non-manifold edges | |
UnusedVertices | 20 | The polymesh contains unused vertices |
See Also