PolymeshPolymeshCheckerFlags Enumeration |
Polymesh check flags, please refer to PolymeshHealthCheckEnum for the corresponding result values.
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
None | 0 | Perform no check | |
LoopVertexUnique | 2048 | To check that no two consecutive vertex index may be the same. | |
VerticesOnSameEdge | 1 | To check outerloop vertices on same edge, distance tolerance 0.01. | |
OuterloopPlanarity | 2 | To check outerloop's planarity, IN_PLANE_EPSILON 1.0e-3. | |
OuterloopSelfIntersection | 4 | To check if outerloop intersects itself, EPSILON 1.E-4 | |
InnerloopPlanarity | 8 | To check innterloop's planarity, IN_PLANE_EPSILON 1.0e-3. | |
InnerloopSelfIntersection | 16 | To check if innerloop intersects itself, EPSILON 1.E-4. | |
InnerloopInsideOuterloop | 256 | To check if innerloop inside outerloop, EPSILON 1.E-4. | |
LoopNormalValidity | 32 | The inner loop is oriented clockwise, the opposite of the outer loop (counterclockwise). | |
FaceEdgeOrientation | 64 | To check face's edge orientation. | |
Multishellness | 128 | To check are there more than one topologically connected components in the polymesh. This checks only through vertex indexes. | |
MultishellnessGeometrical | 16384 | To check are there more than one geometrically connected components in the polymesh. Check with all vertex edge face position containment (includes partial edge touching cases). This check can be slow, the behavior is O(n^2). | |
VerticesOnSamePosition | 512 | To check if there are any vertices that are in the same location, EPSILON 0.01. | |
UnusedVertices | 1024 | To check if there are any unused vertices in the vertex array. | |
NonManifoldEdges | 4096 | Are there non-manifold edges (indirect edge vertices are found for more than 2 faces). | |
NullFaces | 8192 | To check if all vertices of the face are linearly dependent, or having less than 3 vertices, or smaller than allowed edges. | |
All | 511 | To check all criteria. |
See Also