Polymesh Class

The Polygon class represents a polygon object that has its corners at the given points.
The Polygon class represents a polygon object that has its corners at the given points.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelPolymesh

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class Polymesh

The Polymesh type exposes the following members.

Constructors
  NameDescription
Public methodPolymesh
Initializes a new instance of the Polymesh class
Top
Properties
  NameDescription
Public propertyBrep
Gets or sets the polymesh that forms the object geometry.
Top
Methods
  NameDescription
Public methodStatic memberCompareFingerprints
Compares two fingerprints
Public methodStatic memberConvert
Converts a struct of polymeshes to a list of
FacetedBrep
.
Public methodStatic memberConvertInvalidInfoFromStruct
Convert a struct of invalid info to a list of pairs of outer loop index and error code. Read indexes and error codes from the integer list.
Public methodStatic memberConvertToStruct
Converts a
FacetedBrep
to struct dot polymesh.
Public methodStatic memberFingerprint
Gets fingerprint information for input brep
Public methodFromStruct
Converts a struct of polymesh to a
FacetedBrep
.
Public methodStatic memberGetSolidBrep
Gets the cleaned Brep
Public methodToStruct
Converts a
FacetedBrep
to dotnet polymesh struct.
Public methodStatic memberValidate
Converts a
FacetedBrep
to a polymesh and validates.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next