PolygonNode Class

The PolygonNode class represents flat geometry tree node.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelPolygonNode

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class PolygonNode : IGeometryNode

The PolygonNode type exposes the following members.

Constructors
  NameDescription
Public methodPolygonNode
Initializes a new instance of the PolygonNode class.
Top
Properties
  NameDescription
Public propertyContour
Gets or sets the contour points of flat geometry.
Public propertyIsAutomatic
Gets a value indicating whether this geometry node was automatically generated (returns false if it was originally a user-defined part)
Top
Methods
  NameDescription
Public methodAcceptVisitor
Entry method for the visitor pattern
Public methodClone
Creates a new object that is a copy of the current instance.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next