Polycurve Class |
Represents 3D polycurve geometry, which itself is composed of one or more connected curves. The class offers
facilities for iteration through the polycurve, and implements the ICurve interface.
Once this class is constructed, it represents an immutable polycurve. The curves that can be obtained during
iteration are mere copies of the curves in the polycurve, and mutating them won't affect the polycurve. Please
use the PolycurveGeometryBuilder class to build and manipulate this objects of this class.
Since it implements IEnumerable, the curves can be iterated using foreach loops, and it supports
all of the LINQ operations, and it is possible to build arbitrarily complex queries over the curves of this
class.
Inheritance Hierarchy
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
The Polycurve type exposes the following members.
Constructors
Name | Description | |
---|---|---|
Polycurve |
Initializes a new instance of the Polycurve class.
| |
Polycurve(ICurve) |
Initializes a new instance of the Polycurve class from a curve geometry.
| |
Polycurve(PolyLine) |
Initializes a new instance of the Polycurve class from a PolyLine.
The lines are converted to line segments.
|
Properties
Name | Description | |
---|---|---|
EndPoint |
Gets the end point of the polycurve
| |
Length |
Gets the total length of the polycurve
| |
StartPoint |
Gets the start point of the polycurve
|
Methods
Name | Description | |
---|---|---|
Clone |
Creates a deep copy of the polycurve
| |
Equals |
Determines whether the polycurve equals another polycurve
This function only checks for equality among polycurves
| |
GetEnumerator |
This method implements the IEnumerable interface
|
See Also